Saturday 21st September 2024

Network Outage

We are experiencing a network outage. Our networking team is working on resolving it and should have it resolved shortly.

UPDATE 2:53 PM EST: The issue has been identified, and they are working on a resolution now.

** UPDATE** 4:35 PM EST: The data center is still working on resolving the issue.

** UPDATE ** 4:55 PM EST: The issue has been resolved and all services are operational.